ukVac.com Homepage
Forum Home Forum Home > Trading Post > For Sale
  New Posts New Posts RSS Feed - 82S123 & 82S129 PROM replacement PCBs
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Skin:


82S123 & 82S129 PROM replacement PCBs

 Post Reply Post Reply Page  <12
Author
Message
 Rating: Topic Rating: 1 Votes, Average 5.00  Topic Search Topic Search  Topic Options Topic Options
leejsmith View Drop Down
Newbie
Newbie


Joined: 29 Oct 2016
Status: Offline
Points: 93

Feedback: 0
Post Options Post Options   Thanks (0) Thanks(0)   Quote leejsmith Quote  Post ReplyReply Direct Link To This Post Posted: 09 Aug 2018 at 7:53pm
Originally posted by Ace` Ace` wrote:

Looks like you've got a bad TTL some where.

Yes I am sure I have , but so far I have not found it. I dont have many spares so I have removed possible problem chips and swapped then around looking for a new problem, but it always stays the same. As I have worked my way around the board I have found gates that control what is displayed and I can get things to change including getting kong to show up, but still in the wrong place. The other problem I have is I just cant find the correct schematics for my board, I only have the original crazy kong and the pt2 boards have q few different parts especially the sprite buffer ram.
Back to Top
minwah View Drop Down
Senior Member
Senior Member


Joined: 20 Feb 2013
Status: Offline
Points: 1018

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote minwah Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 10:31am
I have received some of the dedicated boards from Phil, and copied Battlezone's idea to make a couple of boards for reading PROMS.

Here is the 82S123 board, which I've copied directly from Battlezone's (albeit on the dedicated board), although I left pin 1 present as it isn't connected to anything:


I can read this as a 'AT27C512' on my MiniPro, although note that you must untick 'Check ID' to get it to read. I've read three PROMS succesfully, all 82S123 equivalents, model 18S030.


Next then, I thought I could use the same principal with one of the 82S129 boards. I checked the pinout for the 82S129 and AT27C512 and figured I just leave out the A8-A15 pins. However, when I read it, I seem to get no data (all FF's). I wasn't sure if I needed to connect the enable pin link, so tried without, set to pin 13 and pin 14 - all seemed to do the same thing. I realise the board isn't designed for this, but seems like it should work. What am I doing wrong?

Many thanks to Phil for the boards and Battlezone for the idea of using the board 'backwards'!
Back to Top
philmurr View Drop Down
Senior Members
Senior Members


Joined: 13 Aug 2003
Location: Hampshire
Status: Offline
Points: 2623

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote philmurr Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 11:07am
Have you connected both enable pins from the 129?
Back to Top
minwah View Drop Down
Senior Member
Senior Member


Joined: 20 Feb 2013
Status: Offline
Points: 1018

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote minwah Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 4:52pm
Originally posted by philmurr philmurr wrote:

Have you connected both enable pins from the 129?


I tried both separately but not together...I wasn't 100% sure about the enable pins while reading.
Back to Top
philmurr View Drop Down
Senior Members
Senior Members


Joined: 13 Aug 2003
Location: Hampshire
Status: Offline
Points: 2623

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote philmurr Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 5:31pm
Originally posted by minwah minwah wrote:

Originally posted by philmurr philmurr wrote:

Have you connected both enable pins from the 129?


I tried both separately but not together...I wasn't 100% sure about the enable pins while reading.


Both need to be enabled to read
Back to Top
minwah View Drop Down
Senior Member
Senior Member


Joined: 20 Feb 2013
Status: Offline
Points: 1018

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote minwah Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 8:15pm
Originally posted by philmurr philmurr wrote:


Both need to be enabled to read


Thanks Phil. I've linked them both and sure enough can read now...

I've read some PROMs and while I get the 256 bytes (duplicated multiple times), the first nibble of each byte is always F, which doesn't seem correct. I double checked which pins I've omitted (A8-A14, have connected A15 but since not using J3 it isn't connected to anything).

Any ideas?
Back to Top
philmurr View Drop Down
Senior Members
Senior Members


Joined: 13 Aug 2003
Location: Hampshire
Status: Offline
Points: 2623

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote philmurr Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 8:21pm
82S129 is 256K x 4 bit. Your programmer will be trying to read 8 bits so one of the nybbles will be F as those data bits aren’t connected to anything at the programmer
Back to Top
minwah View Drop Down
Senior Member
Senior Member


Joined: 20 Feb 2013
Status: Offline
Points: 1018

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote minwah Quote  Post ReplyReply Direct Link To This Post Posted: 02 Oct 2018 at 10:28pm
Originally posted by philmurr philmurr wrote:

82S129 is 256K x 4 bit. Your programmer will be trying to read 8 bits so one of the nybbles will be F as those data bits aren’t connected to anything at the programmer


Aha, I should have realised that. Well that's good then, will fire up the hex editor... Thanks again!
Back to Top
minwah View Drop Down
Senior Member
Senior Member


Joined: 20 Feb 2013
Status: Offline
Points: 1018

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote minwah Quote  Post ReplyReply Direct Link To This Post Posted: 03 Oct 2018 at 12:03pm
Just for reference, in case anyone else wants to do this, here's some pics of my 82S129 board for reading:


Back to Top
Scoobyatgb View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2017
Location: London
Status: Offline
Points: 66

Feedback: 0
Post Options Post Options   Thanks (0) Thanks(0)   Quote Scoobyatgb Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 2018 at 7:43am
Do you have any of these board left as I am trying too fix my double dragon 3 board that has sprites missing
Back to Top
caius View Drop Down
Senior Member
Senior Member
Avatar

Joined: 24 Mar 2013
Status: Offline
Points: 545

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote caius Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 2018 at 10:18am
Originally posted by Scoobyatgb Scoobyatgb wrote:

Do you have any of these board left as I am trying too fix my double dragon 3 board that has sprites missing

You can replace the Double Dragon III BPROM with a GAL16V8, I adapted it some time ago.You can download JED from here:

Back to Top
Scoobyatgb View Drop Down
Newbie
Newbie
Avatar

Joined: 05 Dec 2017
Location: London
Status: Offline
Points: 66

Feedback: 0
Post Options Post Options   Thanks (0) Thanks(0)   Quote Scoobyatgb Quote  Post ReplyReply Direct Link To This Post Posted: 12 Oct 2018 at 7:22pm
Thanks for this i will order all the bits up for this and let you know how I get on

Edited by Scoobyatgb - 12 Oct 2018 at 7:23pm
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 1.070 seconds.