ukVac.com Homepage
Forum Home Forum Home > Technical > Fix logs
  New Posts New Posts RSS Feed - Paddle Battle/Tennis Tourney Repair Log
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Skin:


Paddle Battle/Tennis Tourney Repair Log

 Post Reply Post Reply
Author
Message
Kaizen088 View Drop Down
Groupie
Groupie
Avatar

Joined: 16 Aug 2015
Location: Brisbane, OZ
Status: Offline
Points: 284

Feedback: 0
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kaizen088 Quote  Post ReplyReply Direct Link To This Post Topic: Paddle Battle/Tennis Tourney Repair Log
    Posted: 15 Apr 2018 at 2:05am
I picked this PCB up off Ebay recently, I was a bit disappointed when the board I received was different to the one in the pics on the Ebay ad.
When I contacted the guy he kindly refunded the cost of the board.

This was the board pictured in the listing...


This was the one I received...


The score switch was rusty and one of the chips was damaged.


The board in the listing was in much better condition.

The first thing to do was remove the damaged 9316 (74161) and put a socket in place, I had a good 9316 chip I'd pulled from another board so I fitted that in the socket.
Power and Composite Video out were soldered directly to the bottom of the board as I don't have a 48 pin edge connector and this board takes AC voltage input anyway, +5v DC and Ground were soldered directly to the power rails.
A 56 pin Jamma connector may fit, I'll worry about that later.

I powered it up but nothing was showing up on screen.

As usual I started at the clock and had a good signal coming from the buffer at E6 and the clock divider at F6.
Moving on to the next divider at F8 (7493) I found pin 8 had no output and pin 11 was stuck LO.


The chip was removed and confirmed faulty in the IC tester so I socketed and replaced it with a new 74LS93.

The board was powered up again and I was greeted with a net and ball. 


The horizontal hold needs tweaking but it's not accessible from the rear of the TV.
Time to hook the rest of the controls up so I wired in the coin, start and one 5K paddle pot. Powered it up again and got the pots showing on screen and the game credits up and starts but no score showing.

I started at where the score is mixed with the net, ball and paddles.


I could see no activity on pin 8 of the 7430 at D3, the inputs A-G were all pulsing but pin 1 was stuck LO.
I followed the trace on the board back to C9 Pin 13 and found that on the schematic with a reference back to D3.


When the IC was checked I found the output of the first gate was stuck HI.
C9 was removed and also tested faulty so in went a socket and a new 74LS02 was fitted.

I powered it back up and now have the score display back.



I still have to connect all four paddles up and see why the one I connected is smaller, I remember seeing on one of the schematics where the paddle size can be adjusted but I'll leave that for another day.
The ball also disappears intermittently when you flex the board.

All up a pretty easy repair and another Bronze Age board brought back to life.
These boards are a joy to work on and all up took about an hour to fix.


Edited by Kaizen088 - 15 Apr 2018 at 2:08am
Back to Top
smarty View Drop Down
Senior Members
Senior Members
Avatar

Joined: 14 Oct 2011
Location: Fleet,Hampshire
Status: Offline
Points: 14123

Feedback: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote smarty Quote  Post ReplyReply Direct Link To This Post Posted: 15 Apr 2018 at 8:27am
Good job, nice write up.
jumpnfire.com

MOST WANTED CABS:
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.156 seconds.